Wrong api version at the installation | FUNKWHALE_URL is missing from .env

support

#1

English version

Hello,

I need some help about the installation of this project.

My OS: debian 9, all the dependency are satisfied, I have follow the doc

When I execute the following command (after editing my.env): python api/manage.py migrate

I have the following error: https://pastebin.com/thAudknq

My.env: https://pastebin.com/7YgL2Phm

On funkwhale-troubleshooting I would have been diagnosed with an API problem, what i should do to be able to continue my installation?

With kind regards.

Version française

Bonjour,

Je me permets de me joindre à vous afin de vous demandez un peu d’aide concernant l’installation de ce projet.

Mon OS : debian 9, tous les prérequis en terme de dépendance sont satisfaits, enfin il me semble j’ai suivi la doc.

Lorsque j’exécute la commande suivante (après avoir éditer mon .env) : python api/manage.py migrate j’ai l’erreur suivante : https://pastebin.com/thAudknq

Mon .env : https://pastebin.com/7YgL2Phm

Sur funkwhale-troubleshooting on m’aurais diagnostiquer un problème d’api, que dois-je faire pour pouvoir poursuivre mon installation ?

Bien cordialement.


#2

Hey @majax, I suspect the issues comes from the process not being able to load your .env file. This will be improved in next release, but in the meantime, can you try running ln -s /srv/funkwhale/config/.env /srv/funkwhale/api/.env and see if it fixes your issue ?


closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.