UnRaid Docker install success - User/Pass for Admin?



So I’ve successfully installed this on my UnRaid box using a docker supplied by “thetarkus”. Some tweaking needed to be done though because I don’t think it’s actually complete.

Anyway, I can get to the WebUI but there is no way to login. What is the default User/Pass? I tried searching here but can’t find any info on it.



Hi, @Usafle, you need to create an admin account from the shell (docker exec -it funkwhale manage createsuperuser).

For the record, it’s documented here: https://docs.funkwhale.audio/installation/docker.html#mono-container-installation


That install process is different than the unraid install process… Unraid you just pull down a template from Community Apps and fill in the information. The Template provided no such area to fill in a user/pass.

So now that begs another question; using your CLI that you mentioned, after I’ve already installed the docker, will it work?


yes sure, you can execute this command at any time :slight_smile:


Just tried to do that in the console of Funkwale. Got this in return:

/ # docker exec -it funkwhale manage createsuperuser
sh: docker: not found


Oh, it looks like unRAID offer you a shell directly inside the container, so the command should be even easier!

Can you try with manage createsuperuser ? If it work, you can ignore the docker exec -it funkwhale from every command, as it’s only needed to execute the following bits in the container :slight_smile:


Well we are both learning now. “Superuser created successfully

Time to see what else I can break. LoL

Edit: Logged in. Music library is blank. I’ve got the container pointing to my Music share on unRaid. This is crazy.

Edit2: stopped the container… changed the Music share from “Read only” to “Read and Write”… no difference.

Edit3: Am I missing something here? Should this app not automatically scan and read the entire music library that it is pointing to automatically? I took a look at this page and it sort of sounds like I have to import the music manually… even though it’s already pointing to the share that has all my music files…


@Usafle you need to trigger an import via the CLI (like you did to create the super user account). Instructions/documentation are here, but basically:

  • Visit http://yourdomain/content/libraries/ and create a library
  • Copy the library ID from the url (a7b722cc-df42-4d57-aee7-dc344aa8a6a in the following scheenshot image
  • Run the import command via the CLI: manage import_files a7b722cc-df42-4d57-aee7-dc344aa8a6a "/music/**/*.mp3" --recursive --in-place. This will import all mp3 files in your music directories, and once the import is done, you’ll see your music appearing in the UI :slight_smile:


Thanks! sorry to be such a burden, but some of this stuff I’m learning as I go along. Your commands worked. I even rolled the dice and changed the MP3 to FLAC hoping it would import my FLAC audio files and… it did. So, I am learning.

I got some red errors on a few tracks when importing but they scrolled by so fast, I couldn’t make out what the errors were and then they got “buried” (imported something like 3000 mp3 files) and I could not scroll up to the errors…

But at least I’m making headway a bit.

Again, sorry and again, thanks!


You’re not a burden at all! That’s our job to make Funkwhale usable by anyone, and I have dedicated time to answer support requests such as yours. There is really no trouble :slight_smile:

As for the failed tracks, this may indicate some missing tags or corrupted files. You can safely relaunch an import, this will only pick missing tracks (so, the errored one) and you’ll see what’s going on. You can share the logs here and I’ll tell you what’s wrong !


I know this is old but I ran into this problem this morning while installing on unraid. What I noticed was that on the thetarkus/docker-funkwhale where unraid pulls funkwhale from says to run

docker exec -it funkwhale manage createsuperuser

but when the container was pulled it names it Funkwhale so to be able to execute the command from unraid terminal you only need to capiltize the F

docker exec -it Funkwhale manage createsuperuser


Thank you for sharing @swingline. Is it Unraid’s behaviour to capitalize container names, or did you specify this yourself?


No Unraid doesn’t default to capitalization of all container names. But it will use what is in the name section as in the screenshot. I only used the default options when testing funkwhale. I quickly noticed the issue was just a simple capitalization typo. only posting for the next person using unraid that goes googling for a solution.

closed #14

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.