[Solved] Upgrade failed [0.17 to 0.18.1]


#1

Hi all,

I dont know why but i have follow the documentation to upgrade and its fail.

Witch log can i provide to help ? I havent found some logs into /srv/funkwhale.

service funkwhale-server, funkwhale-worker, funkwhale-beat are running.
But i got a blank page when i got on my funkwhale.domain.tld

and i have follow this to change the nginx configuration

Note
If you use nginx, ensure your funkwhale_proxy.conf file does not contain this:
proxy_set_header X-Forwarded-Host $host:$server_port;
If you have this line present, replace it with:
proxy_set_header X-Forwarded-Host $host;
And reload your nginx server.

I have upgrade an another instance just before (0.18 to 0.18.1) without any problems

I hope someone can help me.

Best regards.

Edit: Is it a problem with HTTP/2 ? Pastebin here

I see HTTP/2 support not enabled (install the http2 and tls Twisted extras)

I have create a separate funkwhale-acces.log and in i’v got : pastebin

If i look to my instance seen alive and up to date.

I whas thinking the problem become from nginx, so i have delete my configuration and setup again the reverse-proxy-setup but its the same i got a blank page


#2

@majax, I’m sorry your instance is broken. Let’s fix that.

I need the following piece of informations to help you:

  • How do you know the upgrade failed? What is the error or unexpected behaviour you are seeing? (share logs / screenshots if relevant)
  • It seems your instance is available on a public domain. Can you share the domain name here? It could help for resolution.
  • Whait was the version you were using, when it was working, and what was the version you were upgrading to?
  • Is your instance installed via docker, or directly on the host (as per our Debian installation guide, for instance)?

Ok, I’ve just seen that. Ideally, I’d like a link to your instance so I can see what’s going on :slight_smile:


#3

@eliotberriot no problem for that, its normal when we use a app still in dev on a prod.

• The upgrade haven’t failed. On https://network.funkwhale.audio I see my instance working and up to date
funkwhale.geekshell.fr | i manage another instance for a friend called funkwhale.dans-ma-bulle.life but this instance whas born in 0.18 (without breaks)
• I whas using 0.17, last topic on my profile can figure out
• Debian in use without docker with all update done

Best regards.


#4

Then I’m sorry but I don’t understand what the actual problem is :s

https://funkwhale.geekshell.fr/ works ok for me. No blank page, I can try to login (it fails since I don’t have any valid credential but the API answer as expected).

Am I missing something?


#5

Wow, well, I’ve been trolled by my cache …

At no time did I think about it, but it’s one of the first things we should check.

I feel really stupid about this. Sorry to have wasted the time of those who gave their time to me.

I promise if there’s a next time, I’ll think about my cache first!

Best regards.


#6

Hey @majax, you don’t need to apologize or feel bad about this. It can happen to anyone, and the important part is that your problem is solved.

I personnaly spend countless days fighting cache issues in my life :smiley:


#7