DSub or UltraSonic not Accepting Login credentials



I’m trying to setup Funkwhale on my Android device.
I cannot get it to accept my credentials.

I read this in the Docs:

### Enabling Subsonic on your Funkwhale account

To log-in on your Funkwhale account from Subsonic clients, you will need to set a separate Subsonic API password by visiting your settings page.

Then, when using a client, you’ll have to input some information about your server:

1. Your Funkwhale instance URL (e.g. https://demo.funkwhale.audio)
2. Your Funkwhale username (e.g. demo)
3. Your Subsonic API password (the one you set earlier in this section)

In your client configuration, please double check the “ID3” or “Browse with tags” setting is enabled.

Unfortunately I don’t see where I can set the password for the DSub API.




when you are logged in on your Funkwhale instance, click on Settings in the grey panel on the left (under the Browse tab). On this Settings page, the last element is Subsonic API Password.

From there you can activate Subsonic access and request a password for it. This is the password you have to use on your Subsonic client. You cannot choose the password yourself, it is generated automatically by Funkwhale.

When setting up your server settings from your client (DSub, Ultrasonic, Clementine, etc.), make sure to check that “Browse with ID3 tags” is checked!

I hope this answers your question.


Unfortunately I still get the same error.
I enter my username in the App and the generated password in the password.
I also set the ID3 tags to enabled.
I tried with SSL allowed and without.

I also copied pasted the generated password.

Thanks for your help


The Subsonic API username is case sensitive, whereas the username on Funkwhale’s web interface is not. You can check your actual username on the web interface, it is written “Logged in as …” on the left panel Browse.

If this doesn’t help, I’m afraid I can’t help you any further, but a more competent person might suggest other options…


Did you use “demo” as the password, or generated another one? Since the demo server is reset every few hours, if you regenerated one, maybe the server was reset in the meantime.

On the demo server (and this server only), you can use demo / demo as your Subsonic credentials.

On DSub (and potentially other Subsonic clients), you have an option to test the connexion. Can you share a screenshot of the error / message when doing that?






Ok, your issue is really weird. I know it’s cumbersome, but can you try copy pasting the password in a text editor (or anywhere else) and ensure the UI value and the paste one match exactly. Especially, I wonder if you have some hiddens spaces at the end.


Thnka you,

It finally worked.
I regenerated the key once more.
And suddenly it was accepted.

I must have done a combination of things wrong, like capital in user name with the correct API and the wrong API with the correct username.

Anyway thank you for the quick support.

closed #11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.