Can't Access UI


#1

Hello,

I am trying to get a running instance of FunkWhale so I can try it out. I first started out with koel, and while it looks cool, it’s really cumbersome and isn’t very customizable. I found out about FunkWhale while trying to find out more about koel.

I still have a lot of questions, but I will try to figure out most of those on my own, as they are mostly docker related.

I have followed the guide to setup FunkWhale using the Docker image, and I am unable to access the UI. I have not yet set up a reverse proxy, but I just want to test it. I tried setting it up the first time, and it didn’t work anyway.

Today, on my Mac running VirtualBox, I installed Ubuntu and I was able to setup FunkWhale using the Docker guide and access the WebUI.

However, I am on my third try with Docker running on Ubuntu Server running on Hyper-V on a full Windows Server 2016 instance. I am able to go through the same steps I did on my VirtualBox vm, however, I still can not access it. I can ping my VM host and without any issue from inside the nginx container. This may be something related to the network, but I don’t understand why it is working fine on my VirtualBox setup.

Then after I get that setup, I figure I am able to mount a CIF share from inside the nginx container and point that as my media folder. Please correct me I am wrong.

Also, is it normal for the funkwhale_api container to have STATUS restarting?

Again, thank you an awesome project, I am excited to get this thing going :smiley:


#2

I am able to edit the .env file edit 127.0.0.1 to 0.0.0.0 and I can access the UI with port 5000. However, when I click register, nothing happens. So I can at least confirm network activity from outside the container to my internal LAN.


#3

Is this normal?
" in init
raise ImproperlyConfigured(“The SECRET_KEY setting must not be empty.”)
django.core.exceptions.ImproperlyConfigured: The SECRET_KEY setting must not be empty."


#4

added the secret key, all containers stay up. Still can’t access front end UI with using the reverse proxy included in docker-compose


#5

Hi @svfusion, I’m sorry for your issue, let’s find a solution! Can you please give me a bit more info for the unreachable UI? Is this a 404, a server error, something else? Can you access API urls such as /api/admin?


#6

@eliotberriot
I have a few things going on here. Let’s just try to get this going on my Ubuntu VM on my Macbook (Using Docker).

Right now, I have gotten to the point of being able to access the nginx from the host. However, I can’t create a user or anything, it just keeps trying to load. I am guessing I need to actual configure the nginx container.

Here is the issue, do I need to login into the container and add the config changes? I tried to do that, and the file system is locked, so I don’t think that I am understanding the instructions properly. Thanks for your replies! Looking forward to getting this thing going!


#7

@svfusion the VM / Docker layers may cause the issues, but anyway you should not have to edit config files in the nginx container.

Things you may want to check:

  • is the nginx container running properly, and does it answer from within your VM?
  • have you done the Reverse Proxy configuration part described here https://docs.funkwhale.audio/installation/index.html#reverse-proxy? I know this may be confusing, but the nginx container bundled with Funkwhale is not meant to act as your host reverse proxy, simply to abstract the complexity of the nginx configuration that is specific to Funkwhale. You’ll need a proxy in front of that.

#8

@eliotberriot

Thanks for responding. Before I try the reverse proxy again, do I need to put it at the API server or the nginx container? Should I just disable the nginx contianer that comes with docker-compose?


#9

Also,

" - /opt/docker-funkwhale/data/django-static:/srv/funkwhale/data/static"
I understand that I need to update the first part, but with what? Which container/server is it pulling the files from?


#10

I’m a bit confused about this, sorry. You need to leave the nginx container as is, and have a reverse proxy on your host with the configuration described here: https://docs.funkwhale.audio/installation/index.html#reverse-proxy

You should not have this hardcoded in your docker-compose.yml . It’s computed dynamically based on your env variables (https://code.eliotberriot.com/funkwhale/funkwhale/blob/develop/deploy/docker-compose.yml#L76)


#11

Thanks for your help.

I have started over from scratch. I setup using the Docker guide, installed nginx on the host. I can access the reverse proxy see the static content, I can’t do anything. I am able to ping the API server from the host, so network is working. I’ve followed this guide to the T and still isn’t working. Is there something obvious that I am missing? I’m following the guide word for word.
Thanks again!