Cant access Funkwhale on unraid docker



i have downloaded the Funkwhale docker to my unraid system and i cannot access the gui i have tried searching but all the docker instructions dont provide any unraid specific.

ive tried to access the .env file but when i follow the docker instructions it says curl doesnt exist and neither does nano


Hi @chrism2015, unfortunately, it seems Unraid is pretty conservative about what’s included in the distribution, and the nano and curl executable are apparently missing. nano is a text editor so maybe there is another one available on your system? You can use any text editor for this step.

As for curl, if it’s not available, you can also open the link in your web browser and copy paste the content by end in your .env file.

Anyway, we’ll be releasing a new version tomorrow, and this includes an alternative Docker deployment that should be easier to setup. If you don’t want to struggle, you can still wait until tomorrow and try the other method, (it will be explained here:


@chrism2015, I just got my docker up and running in Unraid, if you need a hand, let me know. (However I can’t log in because I don’t know what the default user/pass is - which I’m about to post a new thread about LoL)


I really could do with help, i’ve tried the new docker container but that doesn’t download it doesn’t exist apparently


Hopefully this helps you out (I had to delete my previous post because I left my IP exposed on it - not a good idea) If the inline image is too small, I uploaded it to


Hi @Usafle and @chrism2015, I recommend you use the funkwhale/all-in-one:0.18 tag, as shown in our documentation, because I don’t think Thetarkus is building images for new releases automatically :slight_smile:

(This tag is build using Thetarkus Dockerfile)


I tried to do it with the CLI and it failed miserably, some of us aren’t that good yet with CLI, hence the reason why we purchased a license for UnRaid. :wink:


@Usafle I’m really not familiar with unRaid, I was not aware there was a GUI for managing containers. Maybe we could provide an official template? I’d need to find some documentation about how to actually do that though :smiley:


@eliotberriot, that would be great… because I’m really not familiar with CLI stuff. LoL

closed #11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.