413 Error when uploading music


#1

Hello there,
My instance was updated to 0.17 last December and at first, I had no problem uploading my music using the web interface (I’ve never used the CLI).
I don’t know how it started but now I’m unable to upload any music : uploads are “denied : Upload refused, ensure the file is not too big and you have not reached your quota”. I have the 413 network error “Request Entity Too Large”.
However, my files aren’t bigger than before and I’m sure that I haven’t reached my quota (which I can easily change because I’m an admin).
Besides, I don’t see any record of these upload attempts in the celeryworker logs.
Has anyone ever had this problem and found a way to solve it ?
Thanks a lot for your help and your work !


#2

Hi @narf, this error is likely not linked to your quota, and coming from a limit enforced at the webserver (nginx or apache) level. If you are using nginx, can you check what is the value of NGINX_MAX_BODY_SIZE in your env file, and for a client_max_body_size line in your nginx virtualhost file?

Both should be set to a higher value than the size of the files you are trying to upload.

If you are using apache, the relevant setting is LimitRequestBody 104857600 (here 104857600 means 100MB).


#3

Thanks for you answer !
I checked the env file and I have : NGINX_MAX_BODY_SIZE=30M
In the virtualhost file, I have : client_max_body_size ${NGINX_MAX_BODY_SIZE};
Maybe there’s something I’m missing but it seems that 30M is big enough, my files are 5 or 6 MB max !

Edit : My bad, I wasn’t editing the right nginx conf file ! All seems to work well know. Thanks Eliot :slight_smile: